Monday, July 15, 2013

Installing HHVM (Hiphop PHP) 2.1.0 On Centos 6.x

HHVM 2.1.0 was released a day ago (as of writing this blog).  In order to install this stable version on your server / development environment. Follow these steps

1. Configure the Repository as mentioned in my previous post

2. Upgrade to the latest version

sudo yum update hiphop-php

3. Confirm that the package is installed correctly

/usr/bin/hhvm --help

NOTE: You need to re-build your we-application (if you are using repo-authoritative mode) with the current version and then only upgrade your production server, or else you might not have this application working correctly.

Have fun with this stable version.

5 comments:

  1. I get this error when I try to install:

    Error: Package: libtool-2.2.6-15.5.el6.x86_64 (@sl/6.3)
    Requires: gcc = 4.4.4
    Removing: gcc-4.4.7-3.el6.x86_64 (@sl-base/6.3)
    gcc = 4.4.4-15.el6
    gcc = 4.4.7-3.el6
    Updated By: gcc-4.6.3-2.el6.x86_64 (hop5)
    gcc = 4.6.3-2.el6

    ReplyDelete
    Replies
    1. Looks you already have gcc toolchain already installed. Could you try removing the gcc that is coming with the centos (as hhvm requires 4.6 which will be automatically installed) ?

      Ideally, if you have really minimal centos, installation will be smooth. But, dont worry, try the above steps and you will have the package installed with higher version of gcc.

      Delete
  2. I cannot use the repository at all.

    [root@localhost yum.repos.d]# yum install hiphop-php
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: dallas.tx.mirror.xygenhosting.com
    * epel: mirror.umd.edu
    * epel-source: mirror.umd.edu
    * extras: mirrors.gigenet.com
    * updates: mirrors.gigenet.com
    Setting up Install Process
    Resolving Dependencies
    .......
    --> Finished Dependency Resolution
    Error: Package: libtool-2.2.6-15.5.el6.x86_64 (@base)
    Requires: gcc = 4.4.4
    Removing: gcc-4.4.7-3.el6.x86_64 (@base)
    gcc = 4.4.4-15.el6
    gcc = 4.4.7-3.el6
    Updated By: gcc-4.6.3-2.el6.x86_64 (hop5)
    gcc = 4.6.3-2.el6
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

    ReplyDelete
    Replies
    1. do a "yum remove libtool gcc" and then "yum install hiphop-php", things should work like that.

      Delete
  3. This comment has been removed by the author.

    ReplyDelete